A1002 A+B for Polynomials(模拟)

问题

This time, you are supposed to find A+B where A and B are two polynomials.

  • Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1 aN1 *N2 *aN2 … NK aNK

where K is the number of nonzero terms in the polynomial, N**i and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N**K<⋯<N2<N1≤1000.

  • Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

  • Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
  • Sample Output:
3 2 1.5 1 2.9 0 3.2

思考

模拟两个多项式相加并输出结果

用一个数组来存储多项式的系数,输入哪一项的值,就加到哪一项

遍历一遍得到多项式的个数

遍历一遍输出多项式

代码示例

#include <iostream>
using namespace std;
int main(){

    float c[1001] = {0};
    int m,n,t;
    float num;
    scanf("%d",&m);
    for (int i = 0; i < m; i++)
    {
        scanf("%d%f", &t , &num);
        c[t] += num;
    }
    scanf("%d",&n);
    for (int i = 0; i < n; i++)
    {
        scanf("%d%f",&t,&num);
        c[t] += num;
    }
    int cnt = 0;
    for (int i = 0; i < 1001; i++)
    {
        if (c[i] != 0)
        {
            cnt++;
        }
    }
    printf("%d",cnt);
    for (int i = 1000; i >= 0; i--)
    {
        if (c[i] != 0.0)
        {
            printf(" %d %.1f", i, c[i]);
        }
    }
    return 0;
}

(解题时参考了柳婼大大的代码 有兴趣可以去看一下 -> 柳婼のBlog)



算法笔记

本博客所有文章除特别声明外,均采用 CC BY-SA 3.0协议 。转载请注明出处!